訳あってGDLに挑戦

2010年7月13日PC・IT

IDLの開発用ライセンスは今月一杯あるんだけど、GDLが互換だというのでどこまで互換性があるのか試したく、インストールに挑戦してみた。

バイナリパッケージは沈没したので、ソースからコンパイルする事に。

使ったソースは、

これを

rpm -ivh gdl-0.9-0.14.rc4.fc14.src.rpm
yum -y install readline-devel
yum -y install zlib-devel
yum -y install gsl-devel
yum -y install plplot-devel
yum -y install ImageMagick-devel
yum -y install ImageMagick-c++-devel
yum -y install netcdf-devel
yum -y install openmpi-devel

の順番にインストール。

取り合えずconfigureが通るようにはなった。

./configure –with-hdf=no –with-python=no

しかし、結果は、いろいろあり、まだ足りないモジュールとかもありそうなので、もう少し調査かな。

                  GDL – GNU Data Language
—– compilation options: —————————
System:              x86_64-unknown-linux-gnu
Installation prefix: /usr/local
C++ compiler:        g++ -g -O2
OpenMP support:      yes (use –with-openmp=no if your compiler does not support it)
—– optional libraries (consult README/INSTALL): —
wxWidgets:           no  (needs explicit enabling)
Magick:              yes
NetCDF:              yes
HDF4:                no
HDF5:                yes
FFTW:                no  (GSL version used by default)
libproject:          no  (see also MAP_INSTALL)
MPICH:               no  (needs explicit enabling)
Python:              no  (see also PYTHON.txt)
UDUNITS-2:           no  (needs explicit enabling)
GRIB:                no  (needs explicit enabling)
—– notes on auxiliary files: ———————-
– consult MAP_INSTALL for details concerning auxiliary
files needed for mapping support
– SAVE and RESTORE procedures require *.pro files from
the CMSVLIB package (see README for details)
——————————————————
use 'make’ to build and 'make install’ to install GDL

–with-python=noじゃないとダメなんて最低だよね。

大人しくIDLを使えってか?

そろそろIDL8.0が出るようだから、無駄に終わるのかな。

今じゃ知識の足りないLinuxエンジニア・・・。

Posted by かふぇおれ